Hissing/white noise after suspension lowered

Discussion in '2007+ Mustang GT500 Tech' started by TOWGUNNER, Nov 22, 2015.

  1. TOWGUNNER

    TOWGUNNER forum member

    549
    0
    Gentlemen
    Need your help please. I’m having trouble trying to diagnose a noise coming from the rear passenger area of my 2007 GT500 with only 5k miles. The noise that I am hearing is a constant hissing/white noise. It only does it when the car is in motion. It does not go away when applying the brakes or pressing in the clutch. I checked to see if the Ebrake lines were rubbing and that’s a negative. It doesn’t get louder with speed just a consistent noise. I thought it was the caliper rubbing on the brakes/rotors but seems not to be the case? All I had installed were some racecraft lower control arms, Eibach sportline lowering springs, and a racecraft adjustable pan hard bar. All mentioned parts have been on the car less than 100 miles. Is this normal to hear that? I know when messing with the suspension you are going to get a lot of road noise but wasn’t expecting this. If this is normal then I will be fine with it, if it’s not ill be taking It into the dealership to get it looked at since I have warranty on it. I had my son record the noise but having trouble trying to load the video on youtube to post on here. Thanks for your time.
     
  2. stkjock

    stkjock ---- Madmin ---- Staff Member S197 Team Member

    36,778
    395
    are the LCAs poly or rod end?


    it sounds like just added NVH from the suppension upgrades
     
  3. TOWGUNNER

    TOWGUNNER forum member

    549
    0
  4. stkjock

    stkjock ---- Madmin ---- Staff Member S197 Team Member

    36,778
    395
    Those links just bring me to the home page. If they are spherical rod ends, they pass a lot more noise from the chasis. The stock parts hide the noise.
     
  5. TOWGUNNER

    TOWGUNNER forum member

    549
    0
    sorry here are the pics attached. Thanks for the help.
     

    Attached Files:

  6. JUSTA3V

    JUSTA3V Moar Throttle!

    704
    1
    You are defenantly going to pick up some new NVH with those bad boys bolted on.
     
  7. stkjock

    stkjock ---- Madmin ---- Staff Member S197 Team Member

    36,778
    395
    those are rod ends... you'll be hearing a lot more noise as a result. 99% probability that what you're hearing is totally normal.
     
  8. TOWGUNNER

    TOWGUNNER forum member

    549
    0
    Ok thanks gents I'm definitely liking that they keep me going forward and no wheel hop
     
  9. black2008gt

    black2008gt GT500 NOOB

    839
    1
    Its NVH from the supspesion components. Same noise happened when i upgraded to spherical bushings.
     
  10. TOWGUNNER

    TOWGUNNER forum member

    549
    0
    Is the 1/4 mile track open again in San Antonio??? (black2008gt)
     
  11. black2008gt

    black2008gt GT500 NOOB

    839
    1
    yes it is, but closed for winter.
     
    Last edited: Dec 1, 2015
  12. 46Tbird

    46Tbird forum member

    1,226
    2
    Check your rear brake dust shields. They are thin sheet metal and bend easily. You might have done something that pushed one of them up against the rotor.


    [​IMG]
     
  13. TOWGUNNER

    TOWGUNNER forum member

    549
    0
    Yup that was the first thing we checked. That's a negative on that. Thanks.
     
  14. thetylerjames15

    thetylerjames15 Junior Member

    2
    0
    Similar problem

    I have the same type of noise however it only happens when I press in the clutch.. I also have a lowering kit