Saleen Tune Po321 code

Discussion in 'JDM Engineering' started by v6tungsten, Feb 24, 2013.

  1. v6tungsten

    v6tungsten forum member

    602
    8
    I sent an email also. after installing the supercharger the 39 injector tune I have a P0321 code car will turn over and fire but stumbles and dies. Also there is a clicking or knocking that seems to be coming from the throttle body motor that last 2-3 second after ignition key is powered on. This is also with 2 different TB and motors. I tried the old 48 injector tune but have the same results...that did run with the old GT500 throttle body installed with the DOB supercharger. I now have an oem GT throttle body. I pulled both TB motor and throttle position wires out of the loom and everything still looks good with the solder and heat shrink. Same extension used with the DOB supercharger.
     
  2. JimIII@JDM

    [email protected] Senior Member Official Vendor S197 Team Member

    3,065
    5
    The P0321 code reads: Ignition/Distributor Engine Speed Input Circuit Range/Performance.

    It seems something may have been left unplugged, that is what the Range/performance usually means. I'm not sure what the rest of the code pertains to but I think it may be a cam sensor or crank sensor. Go back over the install, if it didn't do this before hand its something that you changed during the install.
     
  3. v6tungsten

    v6tungsten forum member

    602
    8
    I replugged the crank sensor last night. Will recheck other plugs today but i had a Dob supercharger on before and didnt have to extend any of the wiring. Do you have any idea why the TB motor would make noise for 2-3 seconds after key on?
     
    Last edited: Feb 25, 2013
  4. JimIII@JDM

    [email protected] Senior Member Official Vendor S197 Team Member

    3,065
    5
    what sensor is cracked, the TB? get that replaced, it could be causing your problems
     
  5. v6tungsten

    v6tungsten forum member

    602
    8
    That was a typo crank sensor.
     
  6. JimIII@JDM

    [email protected] Senior Member Official Vendor S197 Team Member

    3,065
    5
    ohh, hmmm yeah we were wondering if you checked the crank sensor
     
  7. v6tungsten

    v6tungsten forum member

    602
    8
    I just replugged both cam sensors, plugged both TB sensors, all coils plugged, injectors plugged and evap thing on DS, fuel pressure plugged. I pushed the alternator plug but couldnt 100% check without removing intake. I turned key and the TB goes crazy like its going full open and close for 2-3 seconds. I removed the heat shrink from one end of the TB position extension and the solder looked solid. all wiring ran fine with the DOB kit and the JDM 48 injector tune started the car with the DOB kit installed. Again, the only things changed was the TB, Alternator and injectors with the saleen install.

    Im in training until 1pm ct
     
    Last edited: Feb 25, 2013
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.