Severe vibration

Discussion in '2011+ Ford Mustang V6 3.7L Tech' started by canosoto86, Apr 5, 2019.

  1. canosoto86

    canosoto86 Junior Member

    2
    0
    This is kind of a long post so please bear with me.
    First I purchased this car for very cheap, is a 2012 3.7 and I paid $1,300 for it. According to the owner the clutch was gone, which I can confirm it was.

    Well I towed the car home, order a new Ram Clutch kit w/Billet steel flywheel from LethalPerformance and got it installed. After going for a test drive I notice car has a bad vibration which gets worst as RPM's increase, is not drivetrain related as if I leave the car in neutral and Rev it the vibration is there as well is kind of a vibration/rumbling feeling.
    1. I went ahead and changed the following:
    • Harmonic Balancer
    • Motor Mounts
    • Transmission mount
    The vibration is still there and is very strong, I have been trying to find out what it is but am at at a loss at this point of what could it be, Some say it can be bad main bearings in the motor, but the motor doesn't make noises and the oil is very clean with no metal shaving whatsoever.

    Have anyone here experienced something similar and found a solution with their 3.7's?
     
  2. stkjock

    stkjock ---- Madmin ---- Staff Member Administrator Super Moderator S197 Team Member

    37,146
    499
    did it have any vibration before the clutch install? I know the car wasn't drive-able, but did you run/rev the motor when you inspected the car/got it?
     
  3. canosoto86

    canosoto86 Junior Member

    2
    0
    That's the problem, at idle it doesnt vibrate unless is rev'ed. When I went to get the car I didn't reved the motor, I just idled it swithched through gears and car wouldn't move at all, then I shut it off and checked the oil and since all seemed good I bought it. Am about to take out the transmission and recheck everything, but that's one of my thoughts that maybe the new flywheel is out of balance or pressure plate is defective.