What have you done to your mustang today?

Discussion in 'Mustang Chit Chat' started by *JZ*, Mar 18, 2011.

  1. white95

    white95 boost or bust

    1,964
    76
    I believe I’m in a similar spot with mine and I’m curious if you kept the stock CR or went up/down any?
     
  2. Laga

    Laga Senior Member

    834
    400
    We used forged pistons from DSS which resulted in a CR of 10.12:1. 6BD23B2D-6707-44A4-A38A-A32B5F7F3987.jpeg
     
  3. Mach2burnout

    Mach2burnout 05 Redfire GT

    4,592
    739
    Sorry, (reading comprehension) I misunderstood your comment! I thought you had said the clutch cable broke.


    Sent from my iPhone using Tapatalk
     
  4. Midlife Crises

    Midlife Crises Senior Member

    1,506
    993
    Envy for the new motor. May the E-Force be with you.
     
  5. Andrey Sidorov

    Andrey Sidorov Member

    66
    28
    New headlights and S550 brembos are on from yesterday, hopefully sorting clutch issues today and it will be on the road for a proper datalog and tune, kinda hyped ngl. IMG_4279.jpg
     
    xeninworx likes this.
  6. Juice

    Juice forum member

    4,304
    1,695
    Pulled the 3550, found my clutch issue. What a way to spend the 4th!
    The friction material came off the disk. Wonderful. Well, it has been in there for 15 years. But I was expecting to wear it out, not for it to fall apart.
     
  7. lx92coupe

    lx92coupe forum member

    82
    47
    [​IMG]

    Fixed a loose exhaust bracket and adjusted the tailpipe. Love my lift!


    Sent from my iPhone using Tapatalk
     
  8. Midlife Crises

    Midlife Crises Senior Member

    1,506
    993
    Unloaded car from the trailer and back to the garage it goes. The Drags didn’t go that well. The rear end held up and that is great but I can’t keep a belt on the engine for a complete pass. Four runs and threw the belt three times. Managed an 11.60 after going up in smoke on the line. I have most of what I need to step up to an 8 groove belt so that is what I will try next.
    :driver:
     
  9. Laga

    Laga Senior Member

    834
    400
    How much boost are you pushing?
     
  10. Midlife Crises

    Midlife Crises Senior Member

    1,506
    993
    I have recorded 17.5lbs with the pulley setup I’m running. The alignment looks good on all the idlers and accessories. I think the problem exists with the tensioner. The belt appears to run on the edge of the pulley and I’m sure it ran centered when I installed it.
     
  11. Laga

    Laga Senior Member

    834
    400
    The belt runs on the outside edge of my tensioner pulley also. Currently, I have the DOB Frankentensioner setup. The only way this is possible is if the inside tensioner is bent/ warped. It is one of the things I need to check out before I go from 10 pounds to 12.
     
  12. Midlife Crises

    Midlife Crises Senior Member

    1,506
    993
    I ran a different pulley combination with a Frankentensioner at 16lbs and had no problems at all. When I tried for more boost with a 10% overdrive I hit 18lbs but must not have set it up correctly because the tensioner broke. I will be more diligent in my setup with a new Frankentensioner and 8 rib belt.
     
  13. Gabe

    Gabe Whippled Coyote

    8,219
    1,258
    Received 4 brand new Cooper 255/45/18 tires, which will get installed on the wife's factory GT500 18x9.5 wheels and will probably get used twice a year: to and from the state inspection place. Tons of tread, and they will fit front and rear on both cars, her Shelby and my GT

    Can't wait to see how well they hold the 650 rwtq of the Shelby ... LMAO

    IMG_20220707_181224.jpg


    IMG_20220707_180202011.jpg
     
    xeninworx and EBABlacknChrome like this.
  14. Gabe

    Gabe Whippled Coyote

    8,219
    1,258
    Installed.

    IMG_20220709_143325666~2.jpg
     
    dark steed and xeninworx like this.
  15. Pentalab

    Pentalab forum member

    4,849
    880
    Exactly how much negative camber did u have...that wore out the fronts ??
     
  16. stkjock

    stkjock ---- Madmin ---- Staff Member Administrator Super Moderator S197 Team Member

    39,910
    2,816
    yea, the answer is zero. :)
     
    Gabe likes this.
  17. GlassTop09

    GlassTop09 Senior Member

    760
    306
    Can't say......I didn't ask the tech for the sheet, but I confirmed his statement by checking the caster\camber cam alignment marks I had inscribed on both caster\camber cams & strut\unibody from the last alignment done by same tech prior FLCA changeout & spring changeout......caster marks were still in alignment, so caster wasn't touched thus was still within spec. Both inner\outer tie rods are good & tie rod lock nuts weren't touched so toe wasn't touched. Both FR M-18183-C upper strut mounts were still mounted in same default position w\ notches pointed outward.....only the camber cams were out of alignment thus were the only settings physically changed. Both L&R camber cams were rotated to input positive camber to spindles thus negative camber was excessive according to spec & can only assume that when camber was reset, toe corrected back within spec off the camber reset. From the camber cams current position, camber was fairly far negative (cams are almost at full positive rotation now so around +1.2* to +1.3* of the full +-1.5* adjustment range of the FR M-3B236-A kit to bring both sides back within spec). I have remarked new alignment position on both L\R camber cams to strut for future reference.

    Exactly how much negative camber was there prior I can't say, but the wear line appearing on edges of both inner tire shoulders are a dead giveaway of negative camber\toe out being excessive. Rest of tire tread is still good on both front tires. Can't see the Bullitt springs causing this (front ride height only changed 1\4" higher) but I can definately see the FR M-3075-E kit causing it if they're slightly longer than the OEM units they replaced as that will increase negative camber & potentially cause excessive toe out.

    I didn't make any special alignment requests since this car is mostly a cruiser so assuming that the tech went w\ OEM alignment specs for a '09 GT.

    Car tracked good prior realignment, but it tracks even better now since so as far as I'm concerned all is good now.
     
  18. redfirepearlgt

    redfirepearlgt forum member

    2,350
    180
    Added a Paxton Novi 2200 package (beefcake special) to the recently purchased 14 GTCS. Made 589rwhp/495RWT on 10.5 psi boost on a 90+ degree day. Lowered 1.5" and tasteful mild drag suspension mods as well. Of course OPG and Crank timing gear as well. Some other goodies also. Pics when it gets finished. Had a glitch on the front caster/camber strut plates. Too noisy for a street car. Going to a stock GT500 strut mount.
     
  19. Juice

    Juice forum member

    4,304
    1,695
    IMG_20220711_175502988.jpg IMG_20220711_175450636.jpg IMG_20220711_175438355.jpg IMG_20220711_175417540.jpg Clutch failure identified. This clutch was installed 2006-ish when the 3550 swap went into the 91. Has mostly HPDE miles on it.
     
  20. Laga

    Laga Senior Member

    834
    400
    Now you have to find another 11HP and 5TWT.
     
    redfirepearlgt likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.