2012 steering wheel swap can't get audio controls to work

05 vert

Member
Joined
Jun 15, 2015
Posts
57
Reaction score
16
Today I swapped a 2012 steering wheel in my 06gt. It went great the horn works so does cruise control and the buttons all light up. I cant get the radio controls to work. I have two wpt-440 connectors. I have a pac audio sw1- rc-1 interface. I'm not sure how to wire it though. One end gets plugged into the back of my Jensen radio not sure what else to do thanks for the help
 

05 vert

Member
Joined
Jun 15, 2015
Posts
57
Reaction score
16
I got everything working including the phone button.not the voice button though. I used a pac audio swi-rc-1 interface
 

Monkeyporn

forum member
Joined
Nov 14, 2018
Posts
262
Reaction score
58
I got everything working including the phone button.not the voice button though. I used a pac audio swi-rc-1 interface
So what wheel did you go with ? I don't guess you could help a member of the mustang fam out and tell me how you wired it ? Maybe just take a look at my guide and tell if its rigiht ? Thanks I'd love to see pics if you took any.
 

05 vert

Member
Joined
Jun 15, 2015
Posts
57
Reaction score
16
I used a 2012 steering wheel. With my interface I connected the yellow wire to constant power the red wire to keyed wire one black wire to ground and the other black wire to swc ground the purple wire to the white wire. The blue wire to black white of the inter face. Programming the interface is easy with help of there tech support. Th big thing is having the din switches on the interface correct for your stereo brand. Feel free to ask me any questions since I just finishe this and is fresh in my memory
 

05 vert

Member
Joined
Jun 15, 2015
Posts
57
Reaction score
16
I used that link also just my interface was different so the audio wiring was different
 

Monkeyporn

forum member
Joined
Nov 14, 2018
Posts
262
Reaction score
58
I used a 2012 steering wheel. With my interface I connected the yellow wire to constant power the red wire to keyed wire one black wire to ground and the other black wire to swc ground the purple wire to the white wire. The blue wire to black white of the inter face. Programming the interface is easy with help of there tech support. Th big thing is having the din switches on the interface correct for your stereo brand. Feel free to ask me any questions since I just finishe this and is fresh in my memory

Did you cut either of the loops on your Pac ? Also how does the pac connect ot the WPT 440 plugs ? What wires go where ? I'll be using the GT500 steering wheel so I'm hoping the wiring is the same.
 

05 vert

Member
Joined
Jun 15, 2015
Posts
57
Reaction score
16
My pac was different than the one in that post. It was a pac swi-rc-1. Which has no loops or resistors necessary. I connected the yellow wire with the built in fuse to the yellow wire on the radio harness.which is always live. I connected the red wire to the red wire of the radio harness which only works with the key on.one black wire to radio ground. The other black wire to the steering wheel ground using the wpt-440 connector.the purple wire from swc to the white wire of the pac unit again using the wpt-440 connector. The yellow wire connects to the white with black stripe of the pac unit thru the wpt-440 connector. The blue wire in the swc to steering wheel ground.then I set the din switches on the interface 1thru 8 all up. And 1 thru 3 down and 4 up.my stereo is Jensen and all controls work flawlessly.
 

Monkeyporn

forum member
Joined
Nov 14, 2018
Posts
262
Reaction score
58
Did you cut either of the loops on your Pac ? Also how does the pac connect ot the WPT 440 plugs ? What wires go where ? I'll be using the GT500 steering wheel so I'm hoping the wiring is the same.

You said you used a different PAC what Pac di you use ? Thanks
 

Monkeyporn

forum member
Joined
Nov 14, 2018
Posts
262
Reaction score
58
s-l1600.jpg
Did you get it all working

Haven't attempted it yet just got my Wheel today. I'm still waiting for my WTP1242 plugs to come. Hey did you say you didn't need the 100ohm resistor ? Did you get everything to work if not what doesn't work ?
 

Monkeyporn

forum member
Joined
Nov 14, 2018
Posts
262
Reaction score
58
No resistors. Everything g works except the sync button

Wow thats great that it all works hope I have as good of luck. I've read through again how you wired it up and it have a few questions.

1) you said **The other black wire to the steering wheel ground using the wpt-440 connector.** Which pin is ground in the wpt 440 and where did you plug that wpt in at ? Center of clock spring or under left side ?

2) You said ** the purple wire from swc to the white wire of the pac unit again using the wpt-440 connector.** Again where did you plug this wpt in at ? Center of clock spring or under left side of clock spring ?

3) You said **The yellow wire connects to the white with black stripe of the pac unit thru the wpt-440 connector.** Heres my problem with this my pac only has ONE yellow wire
its the one with the build in fuse which you said I should connect to the radio harness. Which yellow wire are you talking about, in the pac or the steering wheel ?

The last part of the puzzle should be here today my WPT440 thanks for any help you cna give on wiring this mess up.

Brandi
 

05 vert

Member
Joined
Jun 15, 2015
Posts
57
Reaction score
16
The wpt 440 goes on the bottom left of the steering column and the other with 440 goes under the horn on the bottom.when you connect to the wpt 440 you connect a wire from the swc to one wpt 440 and the other wpt 440 runs to the pac unit. Just make sure you use the same wire location on both wpt 440 connections.the yellow wire in the swc connects to the black white wire of the pac. The yellow wire with the fuse connects to the yellow wire of the radio harness
 

Support us!

Support Us - Become A Supporting Member Today!

Click Here For Details

Sponsor Links

Banner image
Back
Top