14 mustang radio time blinking nothing works

Discussion in '2011+ Ford Mustang V6 3.7L Tech' started by JrS197, Dec 5, 2017.

  1. JrS197

    JrS197 Junior Member

    20
    0
    so i have a 14 mustang v6 the radio doesn't work the time just flashes, sometimes it works sometimes it doesn't it'll work for a day and stop for weeks, it is the stock non nav system. I've googled this problems for hours and days and cant find something that can fix it. people have said to pull fuse 3,39,28 and some others i cant remember but none worked. i took the center console off and the face of the stereo maybe thinking something was loose back there but nothing was wrong. checked pins in connectors, all good. don't know what else to do i need some help. thanks
     
  2. John Linck

    John Linck Junior Member

    4
    0
    Maybe it'll make sence to check codes with that OBDII code reader and see maybe there is a short circuit in teh radio wiring? That's the first thing I would do if I were you. Well, after checking the fuses of course haha
     
  3. JrS197

    JrS197 Junior Member

    20
    0
    I did check for codes using a scan tool but there is no codes. Checked fuses too.
     
  4. Brand_New31

    Brand_New31 Junior Member

    1
    0
    Please tell me you found some kind of solution. I have had the same issue and I really dont want to spend north of 700 to fix it.
     
  5. RocketcarX

    RocketcarX 95% of my weight is fuel

    2,651
    164
    If it is similar to the problems the F150s have been having it is either the radio itself or the BCM
     
  6. WJBertrand

    WJBertrand forum member

    429
    13
    BCM?
     
  7. RocketcarX

    RocketcarX 95% of my weight is fuel

    2,651
    164
    Body control module
     
    WJBertrand likes this.
  8. WJBertrand

    WJBertrand forum member

    429
    13
    Thanks is that different to the smart junction box?
     
  9. RocketcarX

    RocketcarX 95% of my weight is fuel

    2,651
    164
    yes, it's a computer
     
    WJBertrand likes this.
  10. Augie

    Augie Junior Member

    1
    0
    Did y'all ever find out what the problem was with your radio mine just blinks the time off and on and it been a while that my mustang hasn't had a radio so I've been researching cause it needs to be fixed so im taking a risk and ordering an Audio control Module because there saying thats the problem
     
  11. Crystal Blethen

    Crystal Blethen Junior Member

    1
    0
    Did that fix it? My radio is doing same thing.
     
  12. totaljustice

    totaljustice Junior Member

    1
    0
    I had the radio in my 2012 V6 start doing the Clock flashing and nothing else would work except to eject the CD. This problem started for me when I took the car out of storage in the spring. Driving along and then there was a loud static sounding pop and everything stopped and the clock was flashing alternately with the radio station. I got the car home and after power off and back on, nothing, so I pulled the fuse and that fixed it for a few more weeks and it did the same thing but the second time all it took was to shut the car off pull the key, open the door and it would work again for a while until a week ago. After this nothing I did would clear whatever was wrong with the radio. So up with the hood, tried the shorting the capacitors trick and still nothing. Then came the unpleasant part, time to tear into the dash and pull the radio out to see if I could find anything obvious. I should mention here that I will exhaust every available resource before replacing most parts on a vehicle as I don’t like parting with my hard earned money for something stupid unless I absolutely have to and besides I like the radio that is in the car so I wasn’t about to go to the aftermarket/junkyard/dealership for this. Anyway, I started looking on different forums and found that others had this problem too but no solution was offered other than the aftermarket/junkyard/dealership advice. Well, let me tell you I found a solution which we’ll get into in a minute and you will not believe what it is.

    So carrying on, I had to get at the radio. To do this you’ll need a 7mm socket, a flashlight, some kind of soft material prying tools and an unbelievable amount of dexterity in your fingers!!! There are a few videos on You Tube concerning removing the radio but none of them mentioned a few key pieces of advice. First, disconnect the negative battery terminal to kill the power to the radio or disconnect the battery completely if you like. Pry the console up from the rear behind the cupholder and inside the rear storage compartment first. It will come up from there with some gentle pressure and carefully lift the rest up moving forward until you get up to the shifter and the last clips will let go and just lift straight up and back. You will have to twist the console out of the way. The videos I saw were with automatics and the console comes right off for that but I have a manual which has the shifter boot attached to it. This makes the job a little more difficult but not impossible. You will also have to unplug the connector for the trunk release/traction control/hazard lights. Pretty simple so far but just remember that all of the connectors you have to mess with have spring loaded retention clips that you have to press on the pull out the plug. Two screws on the bottom will allow you to remove the entire front panel. My pry tool couldn’t get the necessary angle to start from the bottom but I was able to remove it from the top without causing any damage to the foam dash.

    Now the radio is exposed and you will see the screen and the CD player part (some people were calling it the head unit but I don’t know if that’s right or not). There are four screws holding it in that have to be removed and now the fun begins. There are three things on the back that have to be pulled out before the CD player comes out. There are two plugs, wide and narrow, and the antenna wire. It took me an hour just to get the first plug off( the widest one) and another half hour to get the others before I figured something out as over the course of troubleshooting, I had the infernal thing out about 7 times. The antenna wire is the shortest and should come out first. I couldn’t get a good grip on it because there isn’t much space at all but I found that I could grab the radio housing itself and pull on it with a moderate amount of effort and that will pop off. Next is the narrow middle plug which gives you a little more space from a longer wire so I had to hold to spring part down with my finger and pull on the radio and that came out. Lastly, the final wire had enough slack that I was able to near fully get at the wide plug and get it unhooked using both hands. I also need to mention here that you should wrap some cloth around the console as there are sharp edges on the unit and I scratched my console a bit while pulling out the radio.

    Now I had the radio on the bench and decided to take the top of the housing off. No surprises. 6 Screws and it popped off fairly easily. One of the forums I was into mentioned something about bad solder connections or excess flux left over from the manufacturing process that can cause issues over time. After looking inside with a magnifying lamp, I found what looked to be at least one issue. You can see in one of the pictures what I mean just to the right of the round part, that doesn’t look right. My brother happens to be a mechanic and very good with soldering said he would try touching it and any other areas with a soldering iron. While I had to wait a couple of days to have him do that, I continued to see if I could fix it myself. I sprayed electrical contact cleaner all over the board and used a Q-Tip to gently clean anything that might be the culprit and still no improvement.

    Back on the internet I go and ended up going through pages and pages of links and I was finally offered a solution on an F-150 forum. Two posters said that they took the motherboard completely out of the housing and baked it in the oven!!!!! I couldn’t believe it. I mentioned this to my brother and he said that people have to do it with GM instrument cluster circuitry all the time so it sounded possible to him. I figured what the heck if it’s cooked then I’m going to cook it literally as one person said they used 385°F and one said 350°F. It went into the oven at 385°F for 10 minutes(The other Picture). I didn’t wait overnight like the posters did but let it sit for about 3 hours until it was completely cool for me. I put everything back together and it frigging worked!!! I never thought in a million years that it would but it did. Drove around all day and no problems. The theory is that the heat will soften the solder and it will bleed back together.

    The instructions for this are:

    1) Dismantle the radio housing

    2) Remove the cable connecting the CD Player to the circuit board from the circuit board end. There is no plug here. It’s just a flat cable that pulls straight out.

    3) There is heatsink paste on one side. Don’t rub it off or get it on your fingers. It has to be there when you put it back together.

    4) Using a non-coated paper plate and four small crushed up balls of aluminum foil, set the circuit board on top of the balls placed at each corner, being careful to keep clear and any of the circuitry. This allows heat to get under the board. And put it on the paper plate. The other posters mentioned that they also placed foil over the plastic connectors to protect them from the heat but “Ain’t nobody got time for that” so I went commando as you can see. But whatever floats your boat.

    5) Preheat the oven to 385°F or 350°F (I used 385) and bake for 10 minutes until golden brown!!! The plate never burned but it did get golden brown so be careful. Also there were some fumes that came from the oven so the fans all went on and windows opened.

    6) After it’s finished, turn off the heat and let it cool completely before you touch it. DO NOT TOUCH THE CIRCUIT BOARD UNTIL IT IS COMPLETELY COOL. The solder will be hot and any sudden movement may cause components to fall over or fall off which, of course, will completely ensure your radio is ruined.

    Anyway I did this and it worked. Be careful throughout the entire process. You don’t want to damage the interior of your car or cause a fire from the shake and bake. I realize this is long but I just thought people might like to know about this if it helps. Your radio is more than likely useless before you try this anyway so it won’t hurt if it’s your last resort like it was for me. I don’t know if this will last or not but it saved me some money and if the radio acts up again I’ll be doing the same treatment. Good Luck!



    20190911_120512.jpg 20190914_090007.jpg