Anybody know off hand which motor to replace...

Discussion in 'Mustang Chit Chat' started by bujeezus, Nov 6, 2018.

  1. bujeezus

    bujeezus forum member

    2,670
    69
    when the defrost is stuck on 100% of the time. Well it's not on 100%, but when I switch it on to dash vents, floor/dash only the defrost comes on. A part number would be fantastic if you have it. We have 4 motors correct, with 1 being a real bitch to get to (I'm betting that's the one I need to replace).
     
  2. David Young

    David Young Junior Member

    48
    0
    The bad one should 'click' 2-5 times when you first start the engine...
     
  3. bujeezus

    bujeezus forum member

    2,670
    69
    No clicking. Some times it'll already be on defrost as soon as I try and select the vents from the off position and other times it will switch from the dash vents/floor by itself. The defrost does turn on and off with the dial switch so I'm thinking that the switch is alright.
     
  4. groundpounder

    groundpounder forum member

    141
    5
    The one you need to replace is the one located behind the gauge cluster. Which means pulling the console, left knee panel, lower dash panel (under steering wheel), then pull cluster. Then use a combination of 1/4" extensions, elbow joints, and wobble sockets to get the two screws out. I did mine once and have to do it again. I have the Ford part # somewhere, I'll look tomorrow and post it.
     
    bujeezus likes this.
  5. groundpounder

    groundpounder forum member

    141
    5
    Motorcraft YH1865. $38 at Amazon.
     
    bujeezus and Badd GT like this.
  6. bujeezus

    bujeezus forum member

    2,670
    69
    Something told me it was gonna be the difficult one. Thanks a ton for the directions and part #!
     
  7. mean18

    mean18 Junior Member

    2
    0
    Mine did the same thing on my 2005. I simply unplugged the wiring connector to the motor and reconnected it and it started working properly
     
  8. bujeezus

    bujeezus forum member

    2,670
    69
    I've pulled the fuse but it didn't make much difference.