Fuel Issues While Tuning

Joined
Feb 17, 2015
Posts
153
Reaction score
103
Location
Ellicott City, MD
I've been working on a new tune with Lito for the past few weeks, and there seems to be a fueling issue that we can't get around. Whenever I reach full throttle the pressure drop across the injectors plummets, and then oscillates back and forth pretty widely. Similar behavior with the fuel pump duty cycle etc.

I have a few logs from the drag strip this past week; it behaves in a similar fashion on the street shifting at lower rpm. The pcm freaked out in 4th gear and added a ton of timing (ramped up to 32 degrees), ignore that part.

Pressure Drop.jpg

Duty Cycle.jpg

We've gone through quite a few tune revisions that haven't seemed to solve it. Has anyone seen a mechanical issue that causes a similar issue?

I'm running an unmodified GT500 dual fuel pump and ID1000 injectors, with a 2.8 L Kenne Bell, 18 psi of boost. The rest of the fuel system is stock. I had a boost a pump hooked up pre-FPDM, but disabled that at Lito's request. Running pump gas, 93 octane.
 

86GT351

forum member
Joined
Nov 14, 2010
Posts
6,033
Reaction score
903
Location
Sunny South Florida
I've been working on a new tune with Lito for the past few weeks, and there seems to be a fueling issue that we can't get around. Whenever I reach full throttle the pressure drop across the injectors plummets, and then oscillates back and forth pretty widely. Similar behavior with the fuel pump duty cycle etc.

I have a few logs from the drag strip this past week; it behaves in a similar fashion on the street shifting at lower rpm. The pcm freaked out in 4th gear and added a ton of timing (ramped up to 32 degrees), ignore that part.

View attachment 80037

View attachment 80038

We've gone through quite a few tune revisions that haven't seemed to solve it. Has anyone seen a mechanical issue that causes a similar issue?

I'm running an unmodified GT500 dual fuel pump and ID1000 injectors, with a 2.8 L Kenne Bell, 18 psi of boost. The rest of the fuel system is stock. I had a boost a pump hooked up pre-FPDM, but disabled that at Lito's request. Running pump gas, 93 octane.
Understanding Lito requested to disconnect the Boost a Pump...…….Hook it up and see if the issue goes away. Somewhat simple test.
 
Joined
Feb 17, 2015
Posts
153
Reaction score
103
Location
Ellicott City, MD
The Boost a Pump was initially hooked up, the variation in pressure drop was much worse. It has improved without it connected, and Fuel Pump Duty Cycle is around 40 percent under WOT. However, I still get pops, hesitation, and other weird behavior when coming onto full throttle.
 

Racer47

Doesn't have much to say
S197 Team Member
Joined
Sep 11, 2009
Posts
1,065
Reaction score
324
Location
SE Wis
Did you replace the stock connector at the fuel pump rail? There is a pretty severe restriction there. There is also a check valve in the fuel hat to hold fuel pressure when you turn the car off. It makes restarting faster but that is also a restriction.

I was going to piece my own fuel line system together but its cheaper and easier to buy the kit from S&H. Its all -8AN from tank to fuel rail, including a high flow filter. I don't remember my numbers but I went from fuel starved to way more than enough with a gt500 pump and KB 2.6 at 17psi simply by upgrading the fuel line.

As a quick fix attempt, replace the fuel filter. It may be plugged and bypassing causing the surging. But long term, you need better fuel lines. The two links are to the S&H FB pages about the kit. The pics are the fuel restrictions. The last attachment is the directions to install the kit.

If you buy the fuel line kit and sell the boost a pump, cost will be close to even and you'll have a better fuel system because it doesn't need excessively high fuel pump pressure to overcome the fuel line restrictions.

<iframe src="https://www.facebook.com/plugins/post.php?href=https://www.facebook.com/permalink.php?story_fbid=1429703500559814&id=229119453951564&show_text=true&width=500" width="500" height="760" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowfullscreen="true" allow="autoplay; clipboard-write; encrypted-media; picture-in-picture; web-share"></iframe>

<iframe src="https://www.facebook.com/plugins/post.php?href=https://www.facebook.com/permalink.php?story_fbid=1265484160315083&id=229119453951564&show_text=true&width=500" width="500" height="760" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowfullscreen="true" allow="autoplay; clipboard-write; encrypted-media; picture-in-picture; web-share"></iframe>
fuel rail connector.jpg ck valve.jpg
 

Attachments

  • S&H S197 Returnless Line and Filter Upgrade.doc
    773.3 KB · Views: 13
Last edited:

Laga

Senior Member
Joined
Aug 10, 2019
Posts
998
Reaction score
521
Location
Chicago
Did you have a full tank of fuel while testing and at the track? I have no starvation problems with 8# of boost and E85 with the stock fuel setup with a BAP and a full tank of fuel. However, anything less than 5/8 of a tank of fuel @WOT, and the fuel pump gets uncovered and sucks air. Even with your dual pumps, if the fuel is not where the pump is, you will suck air.
Just a thought.
 

Pentalab

forum member
Joined
Mar 5, 2013
Posts
5,214
Reaction score
1,103
Did you check the 'sock' filter that goes on the bottom of the fuel pump ? A few summers ago, my FPDC skyrocketed, and fuel pressure dropped like a rock... only when I tried to get into boost. Turns out the 'sock' filter on the bottom of the oem fuel pump on my 2010 was clogged. 'Easy' fix. (fuel filter had been previously changed).
 
Joined
Feb 17, 2015
Posts
153
Reaction score
103
Location
Ellicott City, MD
I was going to piece my own fuel line system together but its cheaper and easier to buy the kit from S&H. Its all -8AN from tank to fuel rail, including a high flow filter. I don't remember my numbers but I went from fuel starved to way more than enough with a gt500 pump and KB 2.6 at 17psi simply by upgrading the fuel line.

As a quick fix attempt, replace the fuel filter. It may be plugged and bypassing causing the surging. But long term, you need better fuel lines. The two links are to the S&H FB pages about the kit. The pics are the fuel restrictions. The last attachment is the directions to install the kit.

That's a cool looking kit, I like that a lot! From the looks of the info on their page you can upgrade the same system to a return style? I'll reach out to them tomorrow!

I actually replaced the OEM fuel filter just before re-tuning. It had been on my shelf for a while, but I didn't get the impression there was anything wrong with it.


Did you have a full tank of fuel while testing and at the track? I have no starvation problems with 8# of boost and E85 with the stock fuel setup with a BAP and a full tank of fuel. However, anything less than 5/8 of a tank of fuel @WOT, and the fuel pump gets uncovered and sucks air. Even with your dual pumps, if the fuel is not where the pump is, you will suck air.
Just a thought.

I'd say it's rare that I'm at the track with less than half a tank, I don't do anything remotely WOT below a quarter tank to avoid fuel starvation issues like you described. I'd have to guess that it hasn't been dependent on fuel level, but I'll keep an eye on that.

Did you check the 'sock' filter that goes on the bottom of the fuel pump ? A few summers ago, my FPDC skyrocketed, and fuel pressure dropped like a rock... only when I tried to get into boost. Turns out the 'sock' filter on the bottom of the oem fuel pump on my 2010 was clogged. 'Easy' fix. (fuel filter had been previously changed).

I'm thinking about pulling the pump to check that this weekend. I figured since my duty cycle has remained low the sock is probably clear, but at this point it doesn't hurt to look.
 

MrBhp

Senior Member
Joined
Sep 12, 2013
Posts
1,255
Reaction score
1,038
Did you replace the stock connector at the fuel pump rail? There is a pretty severe restriction there. There is also a check valve in the fuel hat to hold fuel pressure when you turn the car off. It makes restarting faster but that is also a restriction.

I was going to piece my own fuel line system together but its cheaper and easier to buy the kit from S&H. Its all -8AN from tank to fuel rail, including a high flow filter. I don't remember my numbers but I went from fuel starved to way more than enough with a gt500 pump and KB 2.6 at 17psi simply by upgrading the fuel line.

As a quick fix attempt, replace the fuel filter. It may be plugged and bypassing causing the surging. But long term, you need better fuel lines. The two links are to the S&H FB pages about the kit. The pics are the fuel restrictions. The last attachment is the directions to install the kit.

If you buy the fuel line kit and sell the boost a pump, cost will be close to even and you'll have a better fuel system because it doesn't need excessively high fuel pump pressure to overcome the

That's some solid kit there. I was not disappointed when I got mine.
 

SVT Rider

Member
Joined
Apr 18, 2017
Posts
64
Reaction score
10
Location
Portland, OR
I notice in the data log snapshots your Battery voltage PID is citing a min of 11.75V. That is too low in my opinion. I would suspect your electrical system (thinking Alternator or Battery as a first suspect).
 
Joined
Feb 17, 2015
Posts
153
Reaction score
103
Location
Ellicott City, MD
I notice in the data log snapshots your Battery voltage PID is citing a min of 11.75V. That is too low in my opinion. I would suspect your electrical system (thinking Alternator or Battery as a first suspect).

Good catch! I actually threw the serpentine belt at the top of the track, the voltage drops off pretty sharply to ~12 volts after that. The voltage stays right around 14.10 volts when everything is working correctly lol.
 

SVT Rider

Member
Joined
Apr 18, 2017
Posts
64
Reaction score
10
Location
Portland, OR
Good catch! I actually threw the serpentine belt at the top of the track, the voltage drops off pretty sharply to ~12 volts after that. The voltage stays right around 14.10 volts when everything is working correctly lol.
Haha, well that would do it. Alright, then that's not suspect.
 

Support us!

Support Us - Become A Supporting Member Today!

Click Here For Details

Sponsor Links

Banner image
Back
Top