Fore return fuel system weird problem.

Discussion in '2005+ Mustang GT 4.6L Tech' started by teeje, Jul 14, 2021.

  1. teeje

    teeje Member

    Age:
    25
    548
    84
    Hey yall. I've recently noticed a weird problem. I have a fore l2 return fuel system with a fc3 staged controller and hobbs switch. If I drive it, then shut it off for a few minutes, it didn't want to start. This has happened twice today. Just cranks but if I unplug the fc3 and plug it back in, it starts right back up?

    Sent from my SM-G998U using Tapatalk
     
  2. crjackson2134

    crjackson2134 Member

    279
    102
    It sounds like a bad controller to me, but not being an expert, I’d contact Fore regarding the issue. Perhaps they can help with diagnosis.
     
  3. 86GT351

    86GT351 forum member

    4,821
    330
    bINGO!
     
  4. teeje

    teeje Member

    Age:
    25
    548
    84
    Even with only 130 miles on it? Hardly any run time :(



    Sent from my SM-G998U using Tapatalk
     
  5. crjackson2134

    crjackson2134 Member

    279
    102
    It happens, but this is why you should contact Fore to help with diagnosis. If they assist you in this, and they reach the same conclusion, there shouldn’t be any issues returning it for a replacement if it’s still in warranty. If it’s not in warranty, this will help you avoid throwing money away on parts you don’t need.
     
  6. Robert Larimer

    Robert Larimer Member

    59
    16
    Actually when digital parts fail it is most often in the 1st few hours of use. It's the nature of the beast.
     
    crjackson2134 likes this.
  7. teeje

    teeje Member

    Age:
    25
    548
    84
    Well yall, I feel really stupid to say the least. Today it happened again so I popped the trunk, wiggled the wires, good. Pushed down on top of the fc3, the two Allen bolts that hood the top on with the fuses were loose. Problem solved... smh...

    Sent from my SM-G998U using Tapatalk
     
    crjackson2134 likes this.
  8. crjackson2134

    crjackson2134 Member

    279
    102
    Glad it was so simple. Free-fix is always good.
     
  9. teeje

    teeje Member

    Age:
    25
    548
    84
    Soon as I tightened that, and snugged the Berlinale ends down, the pumps sounded stronger for sure. I'm gonna have to re set my regulator it seems or atleast make sure it is still at 40psi

    Sent from my SM-G998U using Tapatalk
     
    crjackson2134 likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.