Plug review

Discussion in '2007+ Mustang GT500 Tech' started by stkjock, Nov 7, 2015.

  1. stkjock

    stkjock ---- Madmin ---- Staff Member S197 Team Member

    36,778
    395
    I realize they are not ideal to look at. They were in the car a few thousand miles

    Thanks for any thoughts - I don't expect a gray deal of insights based on the quality of the pics.

    Motor - 5.4l, 4v, 20# on E85

    Drivers side bank, front to back:

    [​IMG]

    [​IMG]

    Passenger side:

    [​IMG]
    [​IMG]
     
  2. DiMora

    DiMora More Is Better

    Age:
    48
    815
    7
    They look good to me. Normal.
     
  3. weather man

    weather man Persistance Is A Bitch S197 Team Member

    13,124
    20
    Didn't see any speckling or tip erosion.
     
  4. lito

    lito forum member

    3,897
    22
    Good, what are you looking for?
     
  5. lito

    lito forum member

    3,897
    22
    Are you using antiseize?
     
  6. stkjock

    stkjock ---- Madmin ---- Staff Member S197 Team Member

    36,778
    395
    Educated opinions.

    Only thing I noticed, was a few seem to have a brown area on one side of the plug and wondere if it meant anything. First pic, first plug, u can seen what I mean.

    Yes a small amount on the threads.
     
  7. avinaj80

    avinaj80 Senior Member S197 Team Member

    1,479
    0
    Looks like optimal burn. Bronze/black coloring is normal. If it was all bronze/brown, It'd be on the lean side. A lot of black, rich.
     
  8. SNAKE08

    SNAKE08 forum member

    224
    0
    They look like the ones I just took out of mine. I was wondering if mine were normal as well only because I didn't remember my 93 and ms109 plugs having some of the same color. I've gone e85 as well.

    Glad to hear they are normal, thanks for posting pics !