6R80 in my 05

Discussion in '2005+ Mustang GT 4.6L Tech' started by 05stroker, Jul 30, 2013.

  1. TzReddy

    TzReddy forum member

    579
    3

    You have pics of which one is monetary switch? Guessing the button goes in between the 2?


    Sent from my iPhone using Tapatalk
     
  2. 429244

    429244 forum member

    315
    2
    Define luck.
    I wired it to work with power sent to the controller, not ground. I use a regular 12volt momentary switch mounted on the center console. That switch used to be my line lock switch. Depending on how fast you car is or when you leave, there are some good button options.
    The only issue I have is the firmware. I don't have the current firmware so sometimes I get OSS code after a burnout. It is a known issue but was not known to me. I'm told the fix is to send the controller back for the update.
     
  3. TzReddy

    TzReddy forum member

    579
    3
    You have pics of how you wired it?


    Sent from my iPhone using Tapatalk
     
  4. 429244

    429244 forum member

    315
    2
    No pictures.
    My button is on the center console and the controller is in the glove box. 12v is present in the console for the 12v power outlet. I tapped power from that wire 12v outlet wire to my transbrake switch. The wire from the transbrake switch goes to the controller (pin 5 I THINK). You will need to adjust jumpers in the controller to use 12v (read the manual). That's the short of it. I also wired my 2-step to the same switch because it uses 12v to activate and they both used at the same time.
     
  5. TzReddy

    TzReddy forum member

    579
    3

    So I grounded the wire. While testing trans brake it seems car still wants to walk after couple seconds. Is that normal?


    Sent from my iPhone using Tapatalk
     
  6. 429244

    429244 forum member

    315
    2
    Walk? What does that mean? Do you see the "b" appear on the controller to confirm that you are pressing the transbrake button? At what rpm is the 2-step set? What converter are you using? How does the transmission shift otherwise?
     
  7. TzReddy

    TzReddy forum member

    579
    3
    Once it gets to 3k rpms car starts to move and trans brake doesnt hold anymore. Its a fti triple disc lock up. Yes the b comes on. How do you set the rpms for the trans brake? I dont see anything under quick 6 settings. Besides that transmission shifts great with 0 issues.
     
  8. 429244

    429244 forum member

    315
    2
    You need a 2-step. The transbrake won't hold your power level against the converter.
     
  9. TzReddy

    TzReddy forum member

    579
    3
    Makes sense. thanks
     
  10. TzReddy

    TzReddy forum member

    579
    3
    Also does anyone has the settings they use on their quick 6 controller such as flex shift options? I know originally it was set on 6 gears (p,R,N, D, 2, 1) I changed it to the 7 (P, R, N, D, 3, 2, 1). Only issue is that in drive it doesnt want to shift unless wot.
     
  11. 429244

    429244 forum member

    315
    2
    I use the 7-position OEM Style Range assignments because I am using a 2005-2009 shifter. I don't have a O/D on-off switch or lamp.
     
  12. TzReddy

    TzReddy forum member

    579
    3
    Seeing you used a 05-09 shifter did you just use cable from newer shifter? Also assuming if used that I could aftermarket shifter for 05-09


    Sent from my iPhone using Tapatalk
     
  13. 429244

    429244 forum member

    315
    2
    I don't have first hand experience with an aftermarket shifter for the 05-09. I am only aware of the TCI shifter and I don't see why it would not work. Look back in this thread. It has been discussed but I can't recall the outcome.
    As for a cable, you need the 6r80 cable from a 2011-2014.
     
  14. TzReddy

    TzReddy forum member

    579
    3
    So today while driving I slowly got into it. Car shifted to 4th and nothing there and quick 6 read full throttle slip. I turned car off and back on and car shifted perfect 1-3, when shifted to 4th nothing there and just slips. Quick 6 issue? Trans issue? At a loss


    Sent from my iPhone using Tapatalk
     
  15. 429244

    429244 forum member

    315
    2
    Make sure there is fluid in it. Check for codes. Send a datalog Baumann.
     
  16. TzReddy

    TzReddy forum member

    579
    3
    Anyone know where to hook up is to buy exedy clutches and a bullet intermediate shaft?


    Sent from my iPhone using Tapatalk
     
  17. drive_55_not

    drive_55_not forum member

    593
    7
  18. TzReddy

    TzReddy forum member

    579
    3
    What 2 step does everyone recommend to run with the transbrake from the quick 6?


    Sent from my iPhone using Tapatalk
     
  19. 05stroker

    05stroker Never enough power guy!

    13,013
    43
    I use the n2mb, and I don't have any trouble with my transbrake holding like mentioned above.